Al actualizar tus respositorios, si te encuentras con el siguieten mensaje:

Err http://es.archive.ubuntu.com hardy/universe virtualbox-ose-modules-2.6.24-16-generic 24
403 Forbidden
Imposible obtener http://es.archive.ubuntu.com/ubuntu/pool/universe/v/virtualbox-ose-modules/virtualbox-ose-modules-2.6.24-16-generic_24_i386.deb 403 Forbidde

Resulta que el fallo es debido a que los repositorios de mis sources ya no eran válidos, la solución pasa por cambiar de repositorios o dejar a Ubuntu que seleccione los más rápidos, para ello accede al Gestor de Paquetes Synaptic, y haz lo siguiente:

  1. En el menú superior, pincha en Configuración –> Repositorios
  2. En Descargar desde, selecciona “Otro
  3. Deja que eliga El mejor servidor

Una vez termine de buscar el mejor servidor, selecciona el que te diga y solucionado, ya deberías poder descargar e instalar de nuevo cualquier paquete.